Ratjoy.com » Forums » Suggestions, Technical Support and Feedback » Is there any workaround to successfully cancel a research q1

Is there any workaround to successfully cancel a research q1

chris plu
CO: chris_999

Post Rating: 0
+ / -

Total Posts: 3
Karma: 30
Joined: Aug 5, 2019
Hi Scott

Is there a workaround for cancelling the research of a new product (Q1)?
I mistakenly clicked on the product icon instead of the pedia icon and unwantedly added the product to the research queue.

I will try to show the situation as well as possible so you can easily lookup in the db.

Company: "D All Electronics"
companyId = 71241
buildingId (frid) = 21123
productId (pid) = 181 (Light Bulb)
queueId = 5898093

Full return from progress_controller.php for research of "light bulb":
id "5898093"
frid "21123"
pid "181"
newlevel "1"
starttime "1621065632"
endtime "1621065632"
rnd_name "Electronics R&D"
name "Light Bulb"

There is still 290 hours left, then the research will reach this one here, we have still 12 days left.
(Luckily my research queue was already filled :-) )

What i have tried so far:

1) Clicking on the X from a browser.

2 ) Just to be sure that it is not a browser problem like at the marketing section of a store, i have set up a post request by Guzzle:

$response = $client->request('POST', 'https://capitalism-online.com/eos/progress_controller.php', [
'form_params' => [
'action' => 'cancel_queue',
'type' => 'rnd',
'queue_id' => 5898093

In both cases the returned answer from progress_controller.php will be:
stdClass Object ( [success] => 1 [slot] => 19 [refund] => 0 )

The answer was [success] => 1 but the item will still show up in the queue.

(I think) the most possible cause of the misbehaviour is time.
As long as the research takes a minimum of 1 second it can be removed from the queue.
But in the case of a new product (and a larger R&D, this one has 16000 m2) the time to research Q1 will be 00:00:00 .

I have played around with researches in the past and have seen the following behaviour:
When i add a new product to the research queue the first Y entries will have a research time of 00:00:00 .
These researches are not removable anymore.
I can only remove something from the queue if it has a research time > 0 second(s) .

As example: if i add a research up to Q100 and the first lets say Q35 is all 00:00:00 .
At Q36 it starts to cost some time: lets say: 00:00:01
Then i could remove Q36 to Q100 all items by clicking on the "x" to remove Q36.
The not removable queues would be Q1 to Q35.

What is also curious about the delivered answer: [refund] => 0
The research of Q1 for Light Bulb costs $100.
(but i am not able to tell if this amount was deducted from my cash, because its too low).

My conclusion:
I am pretty sure that the problem lies on "time".
But i am trying to find any possible cause, so there is a small chance that "time" is not the only problem, maybe it is coupled with a cash problem.
Or maybe it is some sort of a "consequencial failure" because of time !> 0
Correctly it should answer with some value like: [refund] => 100.00 (or [refund] => 10000). Isnt it?
Just to try it out, i successfully cancelled another research (Q167 RC Car), and the answer was:
stdClass Object ( [success] => 1 [slot] => 20 [slot_affected] => 0 [refund] => 36691227895143256 )

Can you help in this case?

PS: if you want me to reproduce the behaviour, i can do that on another company (which i will throw away afterwards), so that you can lookup in the database and get some clue about what is going wrong with researches below 1 second.

chris plu
CO: chris_999

Post Rating: 0
+ / -

Total Posts: 3
Karma: 30
Joined: Aug 5, 2019
Paul Jikanski
RJ: Paul Jikanski
CO: Paul Jikanski

Post Rating: 0
+ / -

Total Posts: 194
Karma: 41
Joined: Jan 19, 2013
You mentioned the marketing issue at stores is a browser problem. Does that mean you have a workaround? I've tried the IE plugin for chrome, and the egde browser, still nothing happens when I click to start marketing.
Algen Galvin
RJ: Ebenezer Goldenheart
CO: Algen Galvin

Post Rating: 0
+ / -

Total Posts: 19
Karma: 13
Joined: Jul 7, 2013
@chris plu Solved HOW? I had the same problem a while back, and it looks to me like the only solution is for Scott to manually edit the data.

@Paul Jikanski See this post: http://www.ratjoy.com/forum/topic/a-workaround-for-spending-on-advertising/1

You need to register or login to post a reply.